Adobe Creative Cloud Application

Incident Report for Sheridan College

Resolved

Adobe has confirmed that they have resolved the performance issues with the Adobe Creative Cloud application.
Posted Jun 10, 2026 - 20:16 EDT

Monitoring

Adobe reported a major incident affecting Adobe Creative Cloud services, resulting in service disruption and degraded functionality for users. The issue is currently open and may only affect some users in North America.

Updates on the status of the issue can be found on the Adobe Status page: https://status.adobe.com/

The IT Service Desk will continue to monitor and update our status page as updates are provided by Adobe.
Posted Jun 10, 2026 - 11:12 EDT